Установка и настройка серверов Linux,создание сайтов, установка и настройка Asterisk PBX, Linux для начинающих и не только.
Получать статьи этого сайта на почту:

 

24
Ноя 2015
sergldom
автор
0
комментариев
Рейтинг статьи:
5
Средняя: 5 (2 оценки)

Подключаем TL-WR1043ND с OpenWRT к OpenVPN серверу

   Сегодня напишем продолжение инструкции и установим подключение к установленному ранее OpenVPN серверу из роутера на OpenWRT.

   В инструкции Прошиваем OpenWRT на роутер TL-WR1043ND для установки OpenVPN мы установили прошивку OpenWRT и я пообещал немного позже рассмотреть установку OpenVPN и Asterisk на данный wifi роутер, вот и продолжаем эту инструкцию.

Обновляем репозиторий выполнив команду:

opkg update

Проверяем какие есть пакеты OpenVPN доступные для установки выполнив команду:

opkg list | grep openvpn

Ответ системы:

collectd-mod-openvpn - 4.10.7-2 - OpenVPN traffic/compression input plugin
openvpn - 2.2.2-2 - Open source VPN solution using SSL
openvpn-devel-nossl - r5d4f5435a421299ed047485d8d99bdf9a0d22fd1-1 - Open source VPN solution using plaintext (no SSL)
openvpn-devel-openssl - r5d4f5435a421299ed047485d8d99bdf9a0d22fd1-1 - Open source VPN solution using OpenSSL
openvpn-easy-rsa - 2.2.2-2 - Simple shell scripts to manage a Certificate Authority

Устанавливаем OpenVPN сервер выполнив команду:

opkg install openvpn

Ответ системы установки сервера:

Installing openvpn (2.2.2-2) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/openvpn_2.2.2-2_ar71xx.ipk.
Installing kmod-tun (3.3.8-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/kmod-tun_3.3.8-1_ar71xx.ipk.
Installing libopenssl (1.0.1g-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/libopenssl_1.0.1g-1_ar71xx.ipk.
Installing zlib (1.2.7-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/zlib_1.2.7-1_ar71xx.ipk.
Installing liblzo (2.06-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/liblzo_2.06-1_ar71xx.ipk.
Configuring kmod-tun.
Configuring zlib.
Configuring libopenssl.
Configuring liblzo.
Configuring openvpn.

   Копируем ключи с OpenVPN сервера установленном по инструкции указанной выше на наш роутер c OpenWRT используя программу Putty по инструкции.

Разархивируем ключи и переносим ключи в папку /etc/openvpn/ выполнив команду:

tar xvf office2.tgz
mv office2/ /etc/openvpn/

Проверяем содержимое папки /etc/openvpn/ выполнив команду:

ls /etc/openvpn/

Ответ системы:

ca.crt    office2.crt   office2.key   office2.ovpn

   Проверяем конфиг подключения клиента openvpn к удаленному OpenVPN серверу заменив ip_openvpn_server 1194 на внешний айпи удаленного OpenVPN сервера и Ваш порт сервера:

vi /etc/openvpn/office2.ovpn

remote ip_openvpn_server 1194
client
dev tun0
proto udp
resolv-retry infinite # this is necessary for DynDNS
nobind
persist-key
persist-tun
ca /etc/openvpn/ca.crt
cert /etc/openvpn/office2.crt
key /etc/openvpn/office2.key
comp-lzo
verb 4
mute 20
verb 3

Вносим изменения в файл /etc/config/openvpn

echo '
package openvpn
config openvpn custom_config
        option enabled 1
        option config /etc/openvpn/office2.ovpn
' > /etc/config/openvpn

Перезагружаем OpenVPN сервер выполняем команду:

/etc/init.d/openvpn restart

   Выполняем команду ifconfig и смотрим поднялся ли интерфейс tun0, если поднялся, должен появится tun0:

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:192.168.255.45  P-t-P:192.168.255.46  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Настроим файрволл:

vi /etc/rc.local

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

# openvpn Server
iptables -I FORWARD -i br-lan -o tun0 -j ACCEPT
iptables -I FORWARD -i tun0 -o br-lan -j ACCEPT
iptables -I INPUT -i tun0 -p tcp --dport 80 -j ACCEPT
iptables -I INPUT -i tun0 -p tcp --dport 139 -j ACCEPT
iptables -I INPUT -i tun0 -p tcp --dport 445 -j ACCEPT
iptables -I INPUT -i tun0 -p udp --dport 137 -j ACCEPT
iptables -I INPUT -i tun0 -p udp --dport 138 -j ACCEPT
iptables -I INPUT -i tun0 -p tcp --dport 901 -j ACCEPT
#iptables -I INPUT -i tun0 -p tcp --dport 9100 -j ACCEPT #printer
iptables -I INPUT -i tun0 -p ICMP --icmp-type 8 -j ACCEPT
iptables -I INPUT -i tun0 -p ICMP --icmp-type 11 -j ACCEPT

iptables -t nat -A POSTROUTING -s 192.168.20.0/24 -o tun0 -j MASQUERADE

exit 0

 

Либо в файл /etc/config/firewall вносим данные выполнив команду:

echo '
#--- VPN ---#
config zone
        option name 'vpn'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option network 'vpn'
        option family 'ipv4'

#--- VPN to LAN ---#
config forwarding
        option dest 'lan'
        option src 'vpn'

#--- LAN to VPN ---#
config forwarding
        option dest 'vpn'
        option src 'lan'
' >> /etc/config/firewall

 

В файл /etc/config/network вносим данные выполнив команду:

echo '
config interface 'vpn'
        option ifname 'tun0'
        option defaultroute '0'
        option peerdns '0'
        option proto 'none'
' >> /etc/config/network

Для применения изменений перезагружаем роутер.

 

Бывает, что автозапуск OpenVPN после перезагрузки роутера не происходит, потому вносим в файл /etc/rc.local:

vi /etc/rc.local
..
/etc/init.d/openvpn restart
exit 0

Перезагружаем роутер.

Проверяем пинг с компьютера подключенного по wifi айпи удаленного OpenVPN сервера:

ping 192.168.20.1
PING 192.168.20.1 (192.168.20.1): 56 data bytes
64 bytes from 192.168.20.1: seq=0 ttl=127 time=39.254 ms
64 bytes from 192.168.20.1: seq=1 ttl=127 time=49.465 ms
64 bytes from 192.168.20.1: seq=2 ttl=127 time=38.769 ms
64 bytes from 192.168.20.1: seq=3 ttl=127 time=37.797 ms

   Сегодня мы установили и настроили подключение OpenVPN клиента к OpenVPN серверу. Немного позже мы рассмотрим установку Asterisk на данный wifi роутер.

   С Вами был Сергей Лазаренко

   Сделаем небольшой перерыв и посмотрим небольшой видео ролик про социальный эксперимент:

Рейтинг статьи: 

5
Средняя: 5 (2 оценки)

Вам понравилась статья? Хотите получать уведомления о выходе новых статей с этого сайта на свой почтовый адрес? Подписывайтесь пожалуйста. Введите свой почтовый адрес и нажмите кнопку Хочу получать статьи!

]]>]]>

 

*Адреса электронной почты не разглашаются и не предоставляются третьим лицам для коммерческого или некоммерческого использования.

 

 
 

 

Добавить комментарий

Filtered HTML

  • Поисковые системы будут индексировать и переходить по ссылкам на разрешённые домены.

  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.

Plain text

  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и параграфы переносятся автоматически.
  • Поисковые системы будут индексировать и переходить по ссылкам на разрешённые домены.

CAPTCHA
Этот вопрос задается для того, чтобы выяснить, являетесь ли Вы человеком или представляете из себя автоматическую спам-рассылку.